What’s Vulnerable › Vulnerabilities
CVE-2025-30217: Frappe has possibility of SQL injection due to improper validations
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-89
Description
Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.
Affected products
- frappe: before 14.93.2; from 15.0.0 before 15.55.0 — fixed in 14.93.2, 15.55.0
How to fix
Upgrade to a fixed version: frappe 14.93.2, 15.55.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30217 or the next vulnerability affects your stack