What’s Vulnerable › Vulnerabilities
CVE-2025-30298: Adobe Framemaker | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-121
Description
Adobe Framemaker versions 2020.8, 2022.6 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: from 2020 before 2020.8; from 2022 before 2022.6 — fixed in 2020.8, 2022.6
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.8, 2022.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30298 or the next vulnerability affects your stack