What’s Vulnerable › Vulnerabilities
CVE-2025-30313: Illustrator | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-125
Description
Illustrator versions 28.7.6, 29.5.1 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.8; from 29.0 before 29.6 — fixed in 28.7.8, 29.6
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.8, 29.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30313 or the next vulnerability affects your stack