What’s Vulnerable › Vulnerabilities

CVE-2025-30328: Animate | Out-of-bounds Write (CWE-787)

Description

Animate versions 24.0.8, 23.0.11 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Animate 23.0.12, 24.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-30328 or the next vulnerability affects your stack