What’s Vulnerable › Vulnerabilities

CVE-2025-30330: Illustrator | Heap-based Buffer Overflow (CWE-122)

Description

Illustrator versions 29.3, 28.7.5 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 28.7.6, 29.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-30330 or the next vulnerability affects your stack