What’s Vulnerable › Vulnerabilities
CVE-2025-30346
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-21 · updated 2026-06-17
- Weakness: CWE-444
Description
Varnish Cache before 7.6.2 and Varnish Enterprise before 6.0.13r10 allow client-side desync via HTTP/1 requests.
Affected products
- varnish-software Varnish Enterprise: 6.0.11-r1, 6.0.11-r2, 6.0.11-r3, 6.0.11-r4, 6.0.11-r5, 6.0.11-r6 (+19)
- Varnish Cache Project Varnish Cache: before 7.6.2 — fixed in 7.6.2
How to fix
Upgrade to a fixed version: Varnish Cache Project Varnish Cache 7.6.2. Check the vendor advisory for mitigations.
References
- https://varnish-cache.org/security/VSV00015.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00027.html
Get alerted when CVE-2025-30346 or the next vulnerability affects your stack