What’s Vulnerable › Vulnerabilities
CVE-2025-30355: Synapse vulnerable to federation denial of service via malformed events
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-20
Description
Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.
Affected products
- matrix-org synapse: before 1.127.1 — fixed in 1.127.1
How to fix
Upgrade to a fixed version: matrix-org synapse 1.127.1. Check the vendor advisory for mitigations.
References
- https://github.com/element-hq/synapse/commit/2277df2a1eb685f85040ef98fa21d41aa4cdd389
- https://github.com/element-hq/synapse/releases/tag/v1.127.1
- https://github.com/element-hq/synapse/security/advisories/GHSA-v56r-hwv5-mxg6
Get alerted when CVE-2025-30355 or the next vulnerability affects your stack