What’s Vulnerable › Vulnerabilities
CVE-2025-30371: Metabase vulnerable to circumvention of local link access protection in GeoJson endpoint
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-28 · updated 2026-06-17
- Weakness: CWE-59
Description
Metabase is a business intelligence and embedded analytics tool. Versions prior to v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8 are vulnerable to circumvention of local link access protection in GeoJson endpoint. Self hosted Metabase instances that are using the GeoJson feature could be potentially impacted if their Metabase is colocated with other unsecured resources. This is fixed in v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8. Migrating to Metabase Cloud or redeploying Metabase in a dedicated subnet with strict outbound port controls is an available workaround.
Affected products
- metabase: before 0.52.16.4; before 1.52.16.4; before 0.53.8; before 1.53.8
References
Get alerted when CVE-2025-30371 or the next vulnerability affects your stack