What’s Vulnerable › Vulnerabilities
CVE-2025-30399: .NET and Visual Studio Remote Code Execution Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-426
Description
Untrusted search path in .NET and Visual Studio allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft .NET: from 9.0.0 before 9.0.6; from 8.0.0 before 8.0.17 — fixed in 8.0.17, 9.0.6
- Microsoft Powershell: from 7.4 before 7.4.11; from 7.5 before 7.5.2 — fixed in 7.4.11, 7.5.2
- Microsoft Visual Studio 2022 version 17.14: from 17.8.0 before 17.8.22; from 17.10.0 before 17.10.16; from 17.12.0 before 17.12.9; from 17.14.0 before 17.14.5 — fixed in 17.10.16, 17.12.9, 17.14.5, 17.8.22
- Microsoft .NET 8.0: from 8.0.0 before 8.0.17 — fixed in 8.0.17
- Microsoft .NET 9.0: from 9.0.0 before 9.0.6 — fixed in 9.0.6
- Microsoft Visual Studio 2022 version 17.10: from 17.10.0 before 17.10.16 — fixed in 17.10.16
- Microsoft Visual Studio 2022 version 17.8: from 17.8.0 before 17.8.22 — fixed in 17.8.22
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.11 — fixed in 7.4.11
- Microsoft PowerShell 7.5: from 7.5.0 before 7.5.2 — fixed in 7.5.2
- Microsoft Visual Studio 2022 version 17.14: from 17.12.0 before 17.12.9 — fixed in 17.12.9
How to fix
Upgrade to a fixed version: Microsoft .NET 8.0.17, 9.0.6; Microsoft Powershell 7.4.11, 7.5.2; Microsoft Visual Studio 2022 version 17.14 17.10.16, 17.12.9, 17.14.5, 17.8.22; Microsoft .NET 8.0 8.0.17; Microsoft .NET 9.0 9.0.6; Microsoft Visual Studio 2022 version 17.10 17.10.16; Microsoft Visual Studio 2022 version 17.8 17.8.22; Microsoft PowerShell 7.4 7.4.11; Microsoft PowerShell 7.5 7.5.2; Microsoft Visual Studio 2022 version 17.14 17.12.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30399 or the next vulnerability affects your stack