What’s Vulnerable › Vulnerabilities
CVE-2025-30509
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-19
- Weakness: CWE-20
Description
Improper input validation for some Intel QuickAssist Technology software before version 2.6.0 within Ring 3: User Applications may allow an escalation of privilege. System software adversary with an authenticated user combined with a low complexity attack may enable data manipulation. This result may potentially occur via local access when attack requirements are not present without special internal knowledge and requires no user interaction. The potential vulnerability may impact the confidentiality (none), integrity (low) and availability (none) of the vulnerable system, resulting in subsequent system confidentiality (none), integrity (none) and availability (none) impacts.
Affected products
- Intel(R) QuickAssist Technology software: before 2.6.0-0018 — fixed in 2.6.0-0018
How to fix
Upgrade to a fixed version: Intel(R) QuickAssist Technology software 2.6.0-0018. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30509 or the next vulnerability affects your stack