What’s Vulnerable › Vulnerabilities
CVE-2025-30610: WordPress WP Social Widget plugin <= 2.2.7 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in catchsquare WP Social Widget wp-social-widget allows Stored XSS.This issue affects WP Social Widget: from n/a through <= 2.2.7.
Affected products
- catchsquare WP Social Widget: before 2.2.8 — fixed in 2.2.8
How to fix
Upgrade to a fixed version: catchsquare WP Social Widget 2.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30610 or the next vulnerability affects your stack