What’s Vulnerable › Vulnerabilities
CVE-2025-30641
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-17 · updated 2026-06-17
- Weakness: CWE-59
Description
A link following vulnerability in the anti-malware solution portion of Trend Micro Deep Security 20.0 agents could allow a local attacker to escalate privileges on affected installations. Please note: an attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.
Affected products
- Trend Micro Deep Security: before 20.0.1; 20.0.1, 20.0.1-update12510, 20.0.1-update14610, 20.0.1-update17380, 20.0.1-update19250, 20.0.1-update21510 (+6) — fixed in 20.0.1
How to fix
Upgrade to a fixed version: Trend Micro Deep Security 20.0.1. Check the vendor advisory for mitigations.
References
- https://success.trendmicro.com/en-US/solution/KA-0019344
- https://www.zerodayinitiative.com/advisories/ZDI-25-240/
Get alerted when CVE-2025-30641 or the next vulnerability affects your stack