What’s Vulnerable › Vulnerabilities
CVE-2025-30653: Junos OS and Junos OS Evolved: LSP flap in a specific MPLS scenario leads to rpd crash
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-09 · updated 2026-06-17
- Weakness: CWE-825
Description
An Expired Pointer Dereference vulnerability in Routing Protocol Daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, adjacent attacker to cause Denial of Service (DoS).On all Junos OS and Junos OS Evolved platforms, when an MPLS Label-Switched Path (LSP) is configured with node-link-protection and transport-class, and an LSP flaps, rpd crashes and restarts. Continuous flapping of LSP can cause a sustained Denial of Service (DoS) condition. This issue affects: Junos OS: * All versions before 22.2R3-S4, * 22.4 versions before 22.4R3-S2, * 23.2 versions before 23.2R2, * 23.4 versions before 23.4R2. Junos OS Evolved: * All versions before 22.2R3-S4-EVO, * 22.4-EVO versions before 22.4R3-S2-EVO, * 23.2-EVO versions before 23.2R2-EVO, * 23.4-EVO versions before 23.4R2-EVO.
Affected products
- Juniper Junos OS: before 22.2; 22.2, 22.2-r1, 22.2-r1-s1, 22.2-r1-s2, 22.2-r2, 22.2-r2-s1 (+22) — fixed in 22.2
- Juniper Networks Junos OS Evolved: before 22.2; 22.2, 22.2-r1, 22.2-r1-s1, 22.2-r1-s2, 22.2-r2, 22.2-r2-s1 (+22) — fixed in 22.2
How to fix
Upgrade to a fixed version: Juniper Junos OS 22.2; Juniper Networks Junos OS Evolved 22.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30653 or the next vulnerability affects your stack