What’s Vulnerable › Vulnerabilities
CVE-2025-30654: Junos OS and Junos OS Evolved: A local, low privileged user can access sensitive information
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-09 · updated 2026-06-17
- Weakness: CWE-200
Description
An Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the User Interface (UI) of Juniper Networks Junos OS and Junos OS Evolved allows a local, low-privileged, authenticated attacker with access to the CLI to access sensitive information. Through the execution of a specific show mgd command, a user with limited permissions (e.g., a low-privileged login class user) can access sensitive information such as hashed passwords, that can be used to further impact the system. This issue affects Junos OS: * All versions before 21.4R3-S10, * from 22.2 before 22.2R3-S5, * from 22.4 before 22.4R3-S5, * from 23.2 before 23.2R2-S3, * from 23.4 before 23.4R2-S3. Junos OS Evolved: * All versions before 21.4R3-S10-EVO, * from 22.2-EVO before 22.2R3-S6-EVO, * from 22.4-EVO before 22.4R3-S5-EVO, * from 23.2-EVO before 23.2R2-S3-EVO, * from 23.4-EVO before 23.4R2-S3-EVO.
Affected products
- Juniper Junos OS: before 21.4; 21.4, 21.4-r1, 21.4-r1-s1, 21.4-r1-s2, 21.4-r2, 21.4-r2-s1 (+49) — fixed in 21.4
- Juniper Networks Junos OS Evolved: before 21.4; 21.4, 21.4-r1, 21.4-r1-s1, 21.4-r1-s2, 21.4-r2, 21.4-r2-s1 (+50) — fixed in 21.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 21.4; Juniper Networks Junos OS Evolved 21.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30654 or the next vulnerability affects your stack