What’s Vulnerable › Vulnerabilities
CVE-2025-30677: Apache Pulsar IO Kafka Connector, Apache Pulsar IO Kafka Connect Adaptor: Sensitive information logged in Pulsar's Apache Kafka Connectors
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-09 · updated 2026-06-17
- Weakness: CWE-532
Description
Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected products
- Apache Software Foundation Apache Pulsar: from 2.3.0 before 3.0.11; from 3.3.0 before 3.3.6; from 4.0.0 before 4.0.4 — fixed in 3.0.11, 3.3.6, 4.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 3.0.11, 3.3.6, 4.0.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zv5fwwrh374r1p5cmksxcd40ssxxko3d
- https://pulsar.apache.org/security/
- http://www.openwall.com/lists/oss-security/2025/04/09/2
Get alerted when CVE-2025-30677 or the next vulnerability affects your stack