What’s Vulnerable › Vulnerabilities
CVE-2025-3076: Elementor Pro <= 3.29.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elementor Website Builder Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_text’ parameter in all versions up to, and including, 3.29.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Elementor Page Builder: before 3.29.1 — fixed in 3.29.1
How to fix
Upgrade to a fixed version: Elementor Page Builder 3.29.1. Check the vendor advisory for mitigations.
References
- https://elementor.com/pro/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0c796ee7-5394-40f3-9158-1a006efbf085?source=cve
Get alerted when CVE-2025-3076 or the next vulnerability affects your stack