What’s Vulnerable › Vulnerabilities
CVE-2025-3077: Betheme <= 28.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Betheme theme for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Button shortcode and Custom CSS field in all versions up to, and including, 28.0.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- MuffinGroup Betheme: before 28.0.4 — fixed in 28.0.4
How to fix
Upgrade to a fixed version: MuffinGroup Betheme 28.0.4. Check the vendor advisory for mitigations.
References
- https://support.muffingroup.com/changelog/
- https://themeforest.net/item/betheme-responsive-multipurpose-wordpress-theme/7758048
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7a0a281d-840f-488f-b9ef-c0df8514b47c?source=cve
Get alerted when CVE-2025-3077 or the next vulnerability affects your stack