What’s Vulnerable › Vulnerabilities
CVE-2025-3082: User may override a view's collation and gain unauthorized access to underlying data
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-284
Description
A user authorized to access a view may be able to alter the intended collation, allowing them to access to a different or unintended view of underlying data. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.20, MongoDB Server v7.0 version prior to 7.0.14 and MongoDB Server v7.3 versions prior to 7.3.4.
Affected products
- MongoDB: from 5.0.0 before 5.0.31; from 6.0.0 before 6.0.20; from 7.0.0 before 7.0.14; from 7.3.0 before 7.3.4 — fixed in 5.0.31, 6.0.20, 7.0.14, 7.3.4
How to fix
Upgrade to a fixed version: MongoDB 5.0.31, 6.0.20, 7.0.14, 7.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3082 or the next vulnerability affects your stack