What’s Vulnerable › Vulnerabilities
CVE-2025-3083: Malformed MongoDB wire protocol messages may cause mongos to crash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-248
Description
Specifically crafted MongoDB wire protocol messages can cause mongos to crash during command validation. This can occur without using an authenticated connection. This issue affects MongoDB v5.0 versions prior to 5.0.31, MongoDB v6.0 versions prior to 6.0.20 and MongoDB v7.0 versions prior to 7.0.16
Affected products
- MongoDB: from 5.0.0 before 5.0.31; from 6.0.0 before 6.0.20; from 7.0.0 before 7.0.16 — fixed in 5.0.31, 6.0.20, 7.0.16
How to fix
Upgrade to a fixed version: MongoDB 5.0.31, 6.0.20, 7.0.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3083 or the next vulnerability affects your stack