What’s Vulnerable › Vulnerabilities
CVE-2025-3084: MongoDB Server may crash due to improper validation of explain command
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-703
Description
When run on commands with certain arguments set, explain may fail to validate these arguments before using them. This can lead to crashes in router servers. This affects MongoDB Server v5.0 prior to 5.0.31, MongoDB Server v6.0 prior to 6.0.20, MongoDB Server v7.0 prior to 7.0.16 and MongoDB Server v8.0 prior to 8.0.4
Affected products
- MongoDB: from 5.0.0 before 5.0.31; from 6.0.0 before 6.0.20; from 7.0.0 before 7.0.16; from 8.0.0 before 8.0.4 — fixed in 5.0.31, 6.0.20, 7.0.16, 8.0.4
How to fix
Upgrade to a fixed version: MongoDB 5.0.31, 6.0.20, 7.0.16, 8.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3084 or the next vulnerability affects your stack