What’s Vulnerable › Vulnerabilities
CVE-2025-30899: WordPress User Registration plugin <= 4.0.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpeverest User Registration user-registration allows Stored XSS.This issue affects User Registration: from n/a through <= 4.0.3.
Affected products
- User Registration & Membership: before 4.0.4; before 5.0.4 — fixed in 4.0.4, 5.0.4
How to fix
Upgrade to a fixed version: User Registration & Membership 4.0.4, 5.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30899 or the next vulnerability affects your stack