What’s Vulnerable › Vulnerabilities
CVE-2025-30907: WordPress SecuPress Free plugin <= 2.2.5.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SecuPress SecuPress Free secupress allows DOM-Based XSS.This issue affects SecuPress Free: from n/a through <= 2.2.5.3.
Affected products
- SecuPress with Simple SSL – Simple and Performant Security: before 2.2.5.4 — fixed in 2.2.5.4
How to fix
Upgrade to a fixed version: SecuPress with Simple SSL – Simple and Performant Security 2.2.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30907 or the next vulnerability affects your stack