What’s Vulnerable › Vulnerabilities

CVE-2025-3108: Unsafe Deserialization in JsonPickleSerializer Enables Remote Code Execution in run-llama/llama_index

Description

A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause includes an insecure fallback mechanism, lack of validation or safeguards, misleading design, and violation of Python security guidelines.

Affected products

How to fix

Upgrade to a fixed version: run-llama/llama_index 0.12.41. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-3108 or the next vulnerability affects your stack