What’s Vulnerable › Vulnerabilities
CVE-2025-31104
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-08-31
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet FortiADC 7.6.0 through 7.6.1, FortiADC 7.4.0 through 7.4.6, FortiADC 7.2.0 through 7.2.7, FortiADC 7.1.0 through 7.1.4, FortiADC 7.0 all versions, FortiADC 6.2 all versions, FortiADC 6.1 all versions, FortiADC 6.0 all versions, FortiADC 5.4 all versions, FortiADC 5.3 all versions, FortiADC 5.2 all versions, FortiADC 5.1 all versions, FortiADC 5.0 all versions, FortiADC 4.8 all versions, FortiADC 4.7 all versions, FortiADC 4.6 all versions, FortiADC 4.5 all versions, FortiADC 4.4 all versions, FortiADC 4.3 all versions, FortiADC 4.2 all versions, FortiADC 4.1 all versions, FortiADC 4.0 all versions, FortiADC 3.2 all versions, FortiADC 3.1 all versions, FortiADC 3.0 all versions may allow attacker to execute unauthorized code or commands via <insert attack vector here>
Affected products
- Fortinet FortiADC: from 6.1.0 before 7.1.5; from 7.2.0 before 7.2.8; from 7.4.0 before 7.4.7; from 7.6.0 before 7.6.2 — fixed in 7.1.5, 7.2.8, 7.4.7, 7.6.2
How to fix
Upgrade to a fixed version: Fortinet FortiADC 7.1.5, 7.2.8, 7.4.7, 7.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31104 or the next vulnerability affects your stack