What’s Vulnerable › Vulnerabilities
CVE-2025-31117: OpenEMR Out-of-Band Server-Side Request Forgery (OOB SSRF) Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-918
Description
OpenEMR is a free and open source electronic health records and medical practice management application. An Out-of-Band Server-Side Request Forgery (OOB SSRF) vulnerability was identified in OpenEMR, allowing an attacker to force the server to make unauthorized requests to external or internal resources. this attack does not return a direct response but can be exploited through DNS or HTTP interactions to exfiltrate sensitive information. This vulnerability is fixed in 7.0.3.1.
Affected products
- openemr: before 7.0.3.1 — fixed in 7.0.3.1
How to fix
Upgrade to a fixed version: openemr 7.0.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/aa6f50efb2971285633fa77ea7a50949408cab12
- https://github.com/openemr/openemr/security/advisories/GHSA-2pvv-ph3x-2f9h
- https://github.com/openemr/openemr/security/advisories/GHSA-2pvv-ph3x-2f9h
Get alerted when CVE-2025-31117 or the next vulnerability affects your stack