What’s Vulnerable › Vulnerabilities
CVE-2025-31121: OpenEMR allows XSS in Patient Image feature
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 7.0.3.1, the Patient Image feature in OpenEMR is vulnerable to cross-site scripting attacks via the EXIF title in an image. This vulnerability is fixed in 7.0.3.1.
Affected products
- openemr: before 7.0.3.1 — fixed in 7.0.3.1
How to fix
Upgrade to a fixed version: openemr 7.0.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31121 or the next vulnerability affects your stack