What’s Vulnerable › Vulnerabilities
CVE-2025-31123: Zitadel Expired JWT Keys Usable for Authorization Grants
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-324
Description
Zitadel is open-source identity infrastructure software. A vulnerability existed where expired keys can be used to retrieve tokens. Specifically, ZITADEL fails to properly check the expiration date of the JWT key when used for Authorization Grants. This allows an attacker with an expired key to obtain valid access tokens. This vulnerability does not affect the use of JWT Profile for OAuth 2.0 Client Authentication on the Token and Introspection endpoints, which correctly reject expired keys. This vulnerability is fixed in 2.71.6, 2.70.8, 2.69.9, 2.68.9, 2.67.13, 2.66.16, 2.65.7, 2.64.6, and 2.63.9.
Affected products
- zitadel: from 2.62.0 before 2.63.9; from 2.64.0 before 2.64.6; from 2.65.0 before 2.65.7; from 2.66.0 before 2.66.16; from 2.67.0 before 2.67.13; from 2.68.0 before 2.68.9 — fixed in 2.63.9, 2.64.6, 2.65.7, 2.66.16, 2.67.13, 2.68.9
How to fix
Upgrade to a fixed version: zitadel 2.63.9, 2.64.6, 2.65.7, 2.66.16. Check the vendor advisory for mitigations.
References
- https://github.com/zitadel/zitadel/commit/315503beabd679f2e6aec0c004f0f9d2f5b53ed3
- https://github.com/zitadel/zitadel/releases/tag/v2.63.9
- https://github.com/zitadel/zitadel/releases/tag/v2.64.6
- https://github.com/zitadel/zitadel/releases/tag/v2.65.7
- https://github.com/zitadel/zitadel/releases/tag/v2.66.16
- https://github.com/zitadel/zitadel/releases/tag/v2.67.13
- https://github.com/zitadel/zitadel/releases/tag/v2.68.9
- https://github.com/zitadel/zitadel/releases/tag/v2.69.9
- https://github.com/zitadel/zitadel/releases/tag/v2.70.8
- https://github.com/zitadel/zitadel/releases/tag/v2.71.6
- https://github.com/zitadel/zitadel/security/advisories/GHSA-h3q7-347g-qwhf
Get alerted when CVE-2025-31123 or the next vulnerability affects your stack