What’s Vulnerable › Vulnerabilities
CVE-2025-31124: Zitadel allows User Enumeration by loginname attribute normalization
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-200
Description
Zitadel is open-source identity infrastructure software. ZITADEL administrators can enable a setting called "Ignoring unknown usernames" which helps mitigate attacks that try to guess/enumerate usernames. If enabled, ZITADEL will show the password prompt even if the user doesn't exist and report "Username or Password invalid". While the setting was correctly respected during the login flow, the user's username was normalized leading to a disclosure of the user's existence. This vulnerability is fixed in 2.71.6, 2.70.8, 2.69.9, 2.68.9, 2.67.13, 2.66.16, 2.65.7, 2.64.6, and 2.63.9.
Affected products
- zitadel: before 2.63.9; from 2.64.0 before 2.64.6; from 2.65.0 before 2.65.7; from 2.66.0 before 2.66.16; from 2.67.0 before 2.67.13; from 2.68.0 before 2.68.9 — fixed in 2.63.9, 2.64.6, 2.65.7, 2.66.16, 2.67.13, 2.68.9
How to fix
Upgrade to a fixed version: zitadel 2.63.9, 2.64.6, 2.65.7, 2.66.16. Check the vendor advisory for mitigations.
References
- https://github.com/zitadel/zitadel/commit/14de8ecac2afafee4975ed7ac26f3ca4a2b0f82c
- https://github.com/zitadel/zitadel/releases/tag/v2.63.9
- https://github.com/zitadel/zitadel/releases/tag/v2.64.6
- https://github.com/zitadel/zitadel/releases/tag/v2.65.7
- https://github.com/zitadel/zitadel/releases/tag/v2.66.16
- https://github.com/zitadel/zitadel/releases/tag/v2.67.13
- https://github.com/zitadel/zitadel/releases/tag/v2.68.9
- https://github.com/zitadel/zitadel/releases/tag/v2.69.9
- https://github.com/zitadel/zitadel/releases/tag/v2.70.8
- https://github.com/zitadel/zitadel/releases/tag/v2.71.6
- https://github.com/zitadel/zitadel/security/advisories/GHSA-67m4-8g4w-633q
Get alerted when CVE-2025-31124 or the next vulnerability affects your stack