What’s Vulnerable › Vulnerabilities
CVE-2025-31128: gifplayer XSS vulnerability
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
gifplayer is a customizable jquery plugin to play and stop animated gifs. gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.
Affected products
- rubentd gifplayer: before 0.3.7
References
- https://github.com/rubentd/gifplayer/commit/2966193d4d066e5a6ba09dbdf1e1c7f8238630c8
- https://github.com/rubentd/gifplayer/security/advisories/GHSA-gr7w-hmch-25g7
- https://www.drupal.org/sa-contrib-2025-032
Get alerted when CVE-2025-31128 or the next vulnerability affects your stack