What’s Vulnerable › Vulnerabilities
CVE-2025-31131: Path Traversal allowing arbitrary read of files in Yeswiki
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-22
Description
YesWiki is a wiki system written in PHP. The squelette parameter is vulnerable to path traversal attacks, enabling read access to arbitrary files on the server. This vulnerability is fixed in 4.5.2.
Affected products
- yeswiki: before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: yeswiki 4.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/commit/f78c915369a60c74ab8f38561ae93a4aaca9b989
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-w34w-fvp3-68xm
Get alerted when CVE-2025-31131 or the next vulnerability affects your stack