What’s Vulnerable › Vulnerabilities
CVE-2025-31132: Raven allows Remote Code Execution due to improper validation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-20
Description
Raven is an open-source messaging platform. A vulnerability allowed any logged in user to execute code via an API endpoint. This vulnerability is fixed in 2.1.10.
Affected products
- The-Commit-Company raven: before 2.1.10
References
Get alerted when CVE-2025-31132 or the next vulnerability affects your stack