What’s Vulnerable › Vulnerabilities
CVE-2025-3130: Obfuscate - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-029
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS.This issue affects Obfuscate: from 0.0.0 before 2.0.1.
Affected products
- Drupal Obfuscate: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Drupal Obfuscate 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3130 or the next vulnerability affects your stack