What’s Vulnerable › Vulnerabilities

CVE-2025-31363: Data exfiltration via AI plugin Jira tool

Description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.4.3, 9.11.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-31363 or the next vulnerability affects your stack