What’s Vulnerable › Vulnerabilities

CVE-2025-31365

Description

An Improper Control of Generation of Code ('Code Injection') vulnerability [CWE-94] in FortiClientMac 7.4.0 through 7.4.3, 7.2.1 through 7.2.8 may allow an unauthenticated attacker to execute arbitrary code on the victim's host via tricking the user into visiting a malicious website.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiClientWindows 7.2.9, 7.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-31365 or the next vulnerability affects your stack