What’s Vulnerable › Vulnerabilities
CVE-2025-31480: aiven-extras allows PostgreSQL Privilege Escalation through format function
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-426
Description
aiven-extras is a PostgreSQL extension. This is a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages the format function not being schema-prefixed. Affected users should install 1.1.16 and ensure they run the latest version issuing ALTER EXTENSION aiven_extras UPDATE TO '1.1.16' after installing it. This needs to happen in each database aiven_extras has been installed in.
Affected products
- aiven-extras: before 1.1.16
References
- https://github.com/aiven/aiven-extras/commit/77b5f19a0c1d196bc741ff5c774f85fe7ca3063b
- https://github.com/aiven/aiven-extras/security/advisories/GHSA-33xh-jqgf-6627
Get alerted when CVE-2025-31480 or the next vulnerability affects your stack