What’s Vulnerable › Vulnerabilities
CVE-2025-31483: Stored XSS in Miniflux Media Proxy due to improper Content-Security-Policy configuration
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Miniflux is a feed reader. Due to a weak Content Security Policy on the /proxy/* route, an attacker can bypass the CSP of the media proxy and execute cross-site scripting when opening external images in a new tab/window. To mitigate the vulnerability, the CSP for the media proxy has been changed from default-src 'self' to default-src 'none'; form-action 'none'; sandbox;. This vulnerability is fixed in 2.2.7.
Affected products
- miniflux v2: before 2.2.7
References
- https://github.com/miniflux/v2/commit/cb695e653a08af4cabcb277c271ce74bd0c746e6
- https://github.com/miniflux/v2/security/advisories/GHSA-cq88-842x-2jhp
Get alerted when CVE-2025-31483 or the next vulnerability affects your stack