What’s Vulnerable › Vulnerabilities
CVE-2025-31496: apollo-compiler Named Fragment Processing Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-07 · updated 2026-06-17
- Weakness: CWE-770
Description
apollo-compiler is a query-based compiler for the GraphQL query language. Prior to 1.27.0, a vulnerability in Apollo Compiler allowed queries with deeply nested and reused named fragments to be prohibitively expensive to validate. Named fragments were being processed once per fragment spread in some cases during query validation, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service in applications. This vulnerability is fixed in 1.27.0.
Affected products
- apollographql apollo-rs: before 1.27.0
References
- https://github.com/apollographql/apollo-rs/pull/952
- https://github.com/apollographql/apollo-rs/security/advisories/GHSA-7mpv-9xg6-5r79
Get alerted when CVE-2025-31496 or the next vulnerability affects your stack