What’s Vulnerable › Vulnerabilities
CVE-2025-31499: Jellyfin Vulnerable to Argument Injection in FFmpeg
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-88
Description
Jellyfin is an open source self hosted media server. Versions before 10.10.7 are vulnerable to argument injection in FFmpeg. This can be leveraged to possibly achieve remote code execution by anyone with credentials to a low-privileged user. This vulnerability was previously reported in CVE-2023-49096 and patched in version 10.8.13, but the patch can be bypassed. The original fix sanitizes some parameters to make injection impossible, but certain unsanitized parameters can still be used for argument injection. The same unauthenticated endpoints are vulnerable: /Videos/<itemId>/stream and /Videos/<itemId>/stream.<container>, likely alongside similar endpoints in AudioController. This argument injection can be exploited to achieve arbitrary file write, leading to possible remote code execution through the plugin system. While the unauthenticated endpoints are vulnerable, a valid itemId is required for exploitation and any authenticated attacker could easily retrieve a valid itemId to make the exploit work. This vulnerability is patched in version 10.10.7.
Affected products
- jellyfin: before 10.10.7 — fixed in 10.10.7
How to fix
Upgrade to a fixed version: jellyfin 10.10.7. Check the vendor advisory for mitigations.
References
- https://github.com/jellyfin/jellyfin/commit/79f3ce53257c5291887cd52d8ac735b5252c9a97
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-2c3c-r7gp-q32m
Get alerted when CVE-2025-31499 or the next vulnerability affects your stack