What’s Vulnerable › Vulnerabilities
CVE-2025-31672: Apache POI: parsing OOXML based files (xlsx, docx, etc.), poi-ooxml could read unexpected data if underlying zip has duplicate zip entry names
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.
Affected products
- Apache Software Foundation Apache POI: before 5.4.0 — fixed in 5.4.0
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache POI 5.4.0. Check the vendor advisory for mitigations.
References
- https://bz.apache.org/bugzilla/show_bug.cgi?id=69620
- https://lists.apache.org/thread/k14w8vcjqy4h34hh5kzldko78kpylkq5
- http://www.openwall.com/lists/oss-security/2025/04/08/2
- https://security.netapp.com/advisory/ntap-20250523-0004/
Get alerted when CVE-2025-31672 or the next vulnerability affects your stack