What’s Vulnerable › Vulnerabilities
CVE-2025-31674: Drupal core - Moderately critical - Gadget Chain - SA-CORE-2025-003
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-915
Description
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Affected products
- Drupal: from 8.0.0 before 10.3.13; from 10.4.0 before 10.4.3; from 11.0.0 before 11.0.12; from 11.1.0 before 11.1.3 — fixed in 10.3.13, 10.4.3, 11.0.12, 11.1.3
How to fix
Upgrade to a fixed version: Drupal 10.3.13, 10.4.3, 11.0.12, 11.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31674 or the next vulnerability affects your stack