What’s Vulnerable › Vulnerabilities

CVE-2025-31675: Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2025-004

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.

Affected products

How to fix

Upgrade to a fixed version: Drupal 10.3.14, 10.4.5, 11.0.13, 11.1.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-31675 or the next vulnerability affects your stack