What’s Vulnerable › Vulnerabilities
CVE-2025-31677: AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal AI (Artificial Intelligence) allows Cross Site Request Forgery.This issue affects AI (Artificial Intelligence): from 1.0.0 before 1.0.2.
Affected products
- Drupal AI (Artificial Intelligence): from 1.0.0 before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: Drupal AI (Artificial Intelligence) 1.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31677 or the next vulnerability affects your stack