What’s Vulnerable › Vulnerabilities
CVE-2025-31679: Ignition Error Pages - Critical - Cross Site Scripting - SA-CONTRIB-2025-007
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Ignition Error Pages allows Cross-Site Scripting (XSS).This issue affects Ignition Error Pages: from 0.0.0 before 1.0.4.
Affected products
- Drupal Ignition Error Pages: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Drupal Ignition Error Pages 1.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31679 or the next vulnerability affects your stack