What’s Vulnerable › Vulnerabilities
CVE-2025-31680: Matomo Analytics - Moderately critical - Cross site request forgery - SA-CONTRIB-2025-008
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Matomo Analytics allows Cross Site Request Forgery.This issue affects Matomo Analytics: from 0.0.0 before 1.24.0.
Affected products
- Drupal Matomo Analytics: from 5.x-1.0 before 8.x-1.24 — fixed in 8.x-1.24
How to fix
Upgrade to a fixed version: Drupal Matomo Analytics 8.x-1.24. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31680 or the next vulnerability affects your stack