What’s Vulnerable › Vulnerabilities
CVE-2025-31682: Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS).This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
Affected products
- Drupal Google Tag: from 7.x-1.0 before 8.x-1.8; from 2.0.0 before 2.0.8 — fixed in 2.0.8, 8.x-1.8
How to fix
Upgrade to a fixed version: Drupal Google Tag 2.0.8, 8.x-1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31682 or the next vulnerability affects your stack