What’s Vulnerable › Vulnerabilities
CVE-2025-31684: OAuth2 Client - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-013
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery.This issue affects OAuth2 Client: from 0.0.0 before 4.1.3.
Affected products
- Drupal OAuth2 Client: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Drupal OAuth2 Client 4.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31684 or the next vulnerability affects your stack