What’s Vulnerable › Vulnerabilities
CVE-2025-31687: SpamSpan filter - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-016
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS).This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.
Affected products
- Drupal SpamSpan filter: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Drupal SpamSpan filter 3.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31687 or the next vulnerability affects your stack