What’s Vulnerable › Vulnerabilities
CVE-2025-31689: General Data Protection Regulation - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-018
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery.This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.
Affected products
- Drupal General Data Protection Regulation: before 3.0.1; from 3.1.0 before 3.1.2 — fixed in 3.0.1, 3.1.2
How to fix
Upgrade to a fixed version: Drupal General Data Protection Regulation 3.0.1, 3.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31689 or the next vulnerability affects your stack