What’s Vulnerable › Vulnerabilities
CVE-2025-31692: AI (Artificial Intelligence) - Critical - Remote Code Execution - SA-CONTRIB-2025-021
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-07-16
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection.This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.
Affected products
- Drupal AI (Artificial Intelligence): before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Drupal AI (Artificial Intelligence) 1.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31692 or the next vulnerability affects your stack