What’s Vulnerable › Vulnerabilities
CVE-2025-31694: Two-factor Authentication (TFA) - Moderately critical - Access bypass - SA-CONTRIB-2025-023
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-288
Description
Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing.This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.
Affected products
- Drupal Two-factor Authentication (TFA): before 8.x-1.10 — fixed in 8.x-1.10
How to fix
Upgrade to a fixed version: Drupal Two-factor Authentication (TFA) 8.x-1.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31694 or the next vulnerability affects your stack